Errors on Hosted Trust Centers

Incident Report for Conveyor

Resolved

We have resolved this issue and continue to investigate the root cause.
Posted Apr 02, 2026 - 07:48 PDT

Investigating

We have identified an issue with hosted trust centers returning "502 Bad Gateway". We are investigating with a high priority.
Posted Apr 02, 2026 - 07:46 PDT
This incident affected: Hosted Trust Centers.